Compatibility issues

View previous topic View next topic Go down

Compatibility issues

Post by sbaudi on Mon May 30, 2016 4:21 pm

In one of your posts today, you said "there have been a lot of audio changes in Android 5 - 6. Since there are a massive number of Android phones, all with add-ons from the manufacturer, it becomes impossible to test for them all." I can imagine that this must be very difficult to deal with, particularly when you are trying to anticipate the best way to handle all the possible audio configurations, timing issues, etc.

One way to help might be to provide some shortcuts (not widgets) to do specific actions. For example, it would be great to have shortcuts to do the following:

1. Switch media stream to bt mono.
2. Switch media stream to bt a2dp.
3. Switch media stream to phone speaker.
4. Turn on bt microphone.
5. Turn off bt michrophone.

This would allow Tasker users to use those shortcuts in various tasks. The reason shortcuts are better than widgets is that it's much more difficult to have Tasker run a widget than a shortcut.

Even better, of course, would be to have a Tasker plugin that allows the user to choose which output path to use for each audio source. Think of it as an alternative to "Let app decide". The plugin wouldn't have to provide access to all the features in the SA user interface, just the ones that redirect audio input and output. That would be incredibly useful.

sbaudi

Posts : 17
Join date : 2015-05-08

View user profile

Back to top Go down

Re: Compatibility issues

Post by sbaudi on Mon May 30, 2016 4:52 pm

Or if you'd rather not develop a plugin, providing intents to do the same thing would also be great.

sbaudi

Posts : 17
Join date : 2015-05-08

View user profile

Back to top Go down

Re: Compatibility issues

Post by SoundAbout on Mon May 30, 2016 5:56 pm

I am thinking of doing that.  What is the different between an exposed Intent and an actual plug-in for Tasker?

I'm guessing that Tasker has some interface that can be applied with specific methods/properties?

The only issue may be the licensing. When a Pro version setting is attempting to change, there could be an error if the trial version has run out and the Pro Key is not available.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Compatibility issues

Post by sbaudi on Mon May 30, 2016 6:03 pm

If you just do an exposed intent, your job is done (except for documenting the interface params). Tasker can send an intent with the proper parameters (action, category, etc.)

For a plugin, all the info is here: http://tasker.dinglisch.net/plugins.html

sbaudi

Posts : 17
Join date : 2015-05-08

View user profile

Back to top Go down

Re: Compatibility issues

Post by sbaudi on Mon May 30, 2016 6:17 pm

By the way, if you do a plugin, you would want to do an "Action", not a "Condition" or "Event" plugin.

sbaudi

Posts : 17
Join date : 2015-05-08

View user profile

Back to top Go down

Re: Compatibility issues

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum