Settings for SlimPort to HDMI

View previous topic View next topic Go down

Settings for SlimPort to HDMI

Post by akatarmo on Mon Jan 25, 2016 3:43 pm

Hello, I bought SoundAbout Pro. I am using a Nexus 5 as GPS car. The Nexus 5 uses a Slimport (similar to MHL) port to send video and audio to HDMI. Please, which is exactly the configuration that must be modified to:

Send image of iGO Primo (GPS software) via Slimport / HDMI to the display of my car. But ... send audio to Nexus 5 speakers . I have tried different settings and get it to work but when I restart the phone and I reload iGO, then I do not hear the audio from the speakers. I have to manually enter SoundAbout and then touching several options, I get to turn the volume on the speakers again. But I will, of course, save the configuration to work always automatically.

Thank you..

akatarmo

Posts : 3
Join date : 2016-01-25

View user profile

Back to top Go down

Re: Settings for SlimPort to HDMI

Post by SoundAbout on Tue Jan 26, 2016 10:02 pm

I think when you plug in the HDMI cord, the phone switches the audio and video to HDMI. Going into SoundAbout and changing the media audio to Speaker changes the audio back to speaker. Do you leave the media audio setting, in SoundAbout on "Speaker"?
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Settings for SlimPort to HDMI

Post by akatarmo on Wed Feb 03, 2016 3:57 pm

Yes, of course. Media audio settings set to speaker.

An example of what happens. Nexus 5 Power ON and:

* Slimport cable unplugged -> Audio phone speakers ON.

* Slimport cable plugged -> Audio phone speakers OFF. Yes, audio and video are redirected over HDMI. Then from the icon of the status bar (SA) I access SoundAbout. And immediately I leave SoundAbout. Then-> Audio phone speakers ON !!!.

* Slimport cable unplugged and plugged in again: Audio phione speakers OFF again.

That is, simply accessing and exiting SA (doing nothing) active the phone speakers when the SlimPort cable is plugged. And the sound remain active in the phone speakers until the cable is unplugged and plugged again.

Please, can you fix this?. I use the Nexus 5 (hidden) with de SlimPort cable as GPS in my car (it is switched on and off with the ignition key). But I need de sound on the phone speakers and, of course, I can not be continuously accessing SA to enable sound.



Someone says this problem in xda forum, here:
http://forum.xda-developers.com/showthread.php?p=33371423#post33371423
"but you can always disconnect and reconnect the câble and the sound is reset automatically over the HDMI"

I hope I explained well, sorry for my bad English.

Update: I tried the new version 2.6.7.2. Same problem.

akatarmo

Posts : 3
Join date : 2016-01-25

View user profile

Back to top Go down

Re: Settings for SlimPort to HDMI

Post by SoundAbout on Sat Feb 06, 2016 11:37 pm

I think it may be a timing issue.  SoundAbout is getting the HDMI plug-in event BEFORE something else on your phone.  So SoundAbout switches to SPEAKER and something else switches to HDMI.  When you open SoundAbout it fires and switches back to SPEAKER.

I changed the event priority to be lower.  Try the latest Beta and see if it makes a difference.

http://soundabout.userboard.net/f8-download-beta-versions
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Settings for SlimPort to HDMI

Post by akatarmo on Sun Feb 07, 2016 7:07 am

Hi. I have tested the new version, but the problem persists. Speakers sound OFF when I plug the HDMI cable. And speakers sound ON when I open SA (from status bar icon) and immediately leave while the HDMI cable is plugged.

Perhaps this can help you to solve the problem:

http://stackoverflow.com/questions/12017297/playing-sound-over-speakers-while-playing-music-through-headphones

Or, at least, solve the problem with a custom version just for me Smile

For example, developing a small apk that only fires a second instance of Sound Alert in background and exit. I use AutomateIt (similar to Tasker) to detect when the phone is powered with the car ignition key and then perform various actions. This way, I could include a new action in AutomateIt to run the app that fires SA and activate audio to speakers.

This could be a temporary solution until you find the way to permanently solve the problem.

How to turn speaker on/off programatically in android 4.0
http://stackoverflow.com/questions/12036221/how-to-turn-speaker-on-off-programatically-in-android-4-0

akatarmo

Posts : 3
Join date : 2016-01-25

View user profile

Back to top Go down

Re: Settings for SlimPort to HDMI

Post by SoundAbout on Sat Mar 19, 2016 2:01 am

The turning the speaker on and off works as in the links that you posted.  When you open SoundAbout that code is working.   It is just a timing issue.

There is code that detects when HDMI is plugged in.  When HDMI is detected, it does check the media audio setting to switch to speaker (if speaker is set as the media audio setting).

One thing that I noticed is that when plugging in the HDMI, it can take the phone 10-12 seconds to accept the call to switch the audio from HDMI to the phone speaker.  My guess is that since this is not "normal" so the phone responds slowly.  This behavior can vary for different phones.  

When I looked into iGo Primo,  I noticed posts mentioning the use of Text To Speech.  Have you looked into setting SoundAbout "Media Audio" back to "Let app decide" and instead use the Sound TTS settings?  

The configuration mentions other Navigation apps but would be the same for you.  The thread is here:
http://soundabout.userboard.net/t418-using-google-navigation-waze-or-co-pilot-and-even-ivona-for-the-voices

Also, there is another new Beta version here:
http://soundabout.userboard.net/f8-download-beta-versions
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Settings for SlimPort to HDMI

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum