Silent mode not working

View previous topic View next topic Go down

Silent mode not working

Post by adrian7000 on Thu Nov 12, 2015 8:43 am

There is one problem with this app. When I try to put phone in silent mode it automatically turns the ringer back on. When I set SoundAbout status to "Off" then I can put the phone to silent and turn Soundabout back on and the phone remains in silent mode. I tried setting "Current Phone Setting (Headset only)" but that will just make my phone silent while it will still be set to ringer mode. Then if I want the notifications again, I need to go to soundabout and change the Alert setting again.

Is it possible to use built in android sound controls while soundabout is on? With previous version of soundabout it worked on this same version of android. I am using android 5.1.1. and the latest version of the app.

adrian7000

Posts : 3
Join date : 2015-11-12

View user profile

Back to top Go down

Re: Silent mode not working

Post by SoundAbout on Sun Nov 15, 2015 3:25 pm

Are you setting the:
"Notifications to"setting to "Current Phone Setting (Headset only)" ?
OR
"Ringtones to" setting to "Current Phone Setting (Headset only)" ?

The Notification To setting has to change the phone's ringer mode because there is no warning when a notification is about to play (there is for ringer).

The problem is that Android 5.0+ introduced these notification settings. In order for SoundAbout to do the things that it does, it may need to put the phone in Silent mode, Vibrate mode, or take the phone out of these modes.

Are you allowing SoundAbout access to the notification listener? This is in phone settings / Notifications/ Notification access / "SA Notification Listener"/

If the listener is ON and you have the Alert behavior/ Wired Headset behavior/ Notification to/ "Headset only (override)" , Then plugging in the wired headphones will turn the phone ringer mode on, but it will only play in the headset. If you switch the phone to silent mode and un-plug the headset, then SoundAbout will remember the silent mode change and switch the ringer mode back to silent mode.



SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Silent mode not working

Post by adrian7000 on Sun Nov 15, 2015 8:24 pm

Thanks for the reply. My problem is that my phone "thinks" that wired headset is always plugged in(headphone jack sensor doesn't work correctly). So when someone calls me sound is not output through earpiece but through headset(which is not plugged in). Same thing if I try to play music it is not output through speaker.

So I only want to use SoundAbout to route calls to earpiece and media audio through speaker. I don't want to override any notification or ringer sounds. Notification listener is enabled. Both "Notification to" and "Ringtones to" are set to "Current Phone Setting" (that is the default setting right?).

Now my phone is set to ringer mode and I can set it to vibrate but as soon as I set it to silent it switches back to ringer immediately. If I switch SoundAbout off, I can set it to silent.

Interesting part is that I didn't update SoundAbout for 6 or more months maybe. In the meantime I upgraded my phone from 4.4 to 5.1 and SoundAbout still worked and I had no trouble switching to silent. But this new SoundAbout version blocks silent mode.

So is there any solution to this? Feel free to ask something more if you need more info

adrian7000

Posts : 3
Join date : 2015-11-12

View user profile

Back to top Go down

Re: Silent mode not working

Post by SoundAbout on Mon Nov 16, 2015 9:20 pm

First, are you setting "Media audio" setting to "Speaker" and "Phone call audio" setting to "Earpiece?

You can try setting those both to "Let app decide" and then go into "Connectable devices" / "Wired Headset settings" / and unc-heck "Wired headset detection"

I just tried setting my phone alert behavior settings to:
Notifications to"setting to "Current Phone Setting"

I put my phone in silent mode and plugged in headphones and unplugged them. The phone stayed in silent mode.

Take a look at your interrupt and priority settings in Android 5.1:
http://www.androidauthority.com/android-lollipop-priority-interruptions-575343/

There might be a trigger configured for a wired headset being plugged in. SoundAbout can't block other apps or Android from detecting those bad headset plug-in signals.


SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Silent mode not working

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum