Alarms don't play with SoundAbout running

View previous topic View next topic Go down

Alarms don't play with SoundAbout running

Post by jpschewe on Thu Aug 06, 2015 8:39 am

Routing audio to my mono bluetooth headset works. When I turn off my headset and play media the sound comes out of my phone's speaker as expected. However once I've started SoundAbout, even if I tell it to turn off, I don't hear my alarms. I typically hear a single beep instead of the alarm music. This is both for alarms from the clock app and for alarms from Google Calendar. If I kill the SoundAbout process, then I hear my alarms again.

What can I do to fix this without needing to kill SoundAbout all of the time?

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Thu Aug 06, 2015 11:09 am

That's odd, as alarms are normally on a completely different audio channel than media and notifications. What phone and version of Android?
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Thu Aug 06, 2015 11:17 am

Motorola Droid Razr HD, Android 4.4.2. I checked and I get the ring tones when my phone is ringing, but not the alarms or calendar notifications.

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Thu Aug 06, 2015 9:14 pm

Now this evening I got my calendar notifications and my alarm worked. So this may be an intermittent thing. I'll keep you updated on how it behaves.

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Fri Aug 07, 2015 12:49 pm

Be aware, sound profiles in Android can also change behavior.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Fri Aug 07, 2015 11:06 pm

I'm not sure what you mean by "sound profiles". I don't have an app for changing my audio other than SoundAbout.

Update from today:
Rebooted phone last night
Opened app after reboot
Heard alarm this morning
Heard hangouts notification this morning
Listened to podcast with Bluetooth mono headset
Turned off headset
About an hour later received hangouts notice and just got beep instead of the regular tone
At the end of the day, the same thing happened with my calendar notification
Listened to another podcast with Bluetooth mono headset
turned off headset
About an hour later alarm went off and I heard it just fine

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Sat Aug 08, 2015 9:17 pm

After shutting off Bluetooth headset:

1) Does the SoundAbout status bar notification stay on "Bluetooth (mono) for media" or does it switch to "Phone speaker for media"?

2) Are you changing the "Media Audio" setting to Bluetooth (mono) to listen to podcasts? Do you change it back to "Let app decide" when finished listening to the podcast?

3) If you click on "Alert behavior", then "Bluetooth (mono) behavior", what is "Notifications to" setting?
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Sun Aug 09, 2015 1:06 am

1) I believe it says "phone speaker for media". I'll watch that closer the next time this happens.
2) I have Media audio always set to Let App Decide. I have set Connectable devices->Bluetooth Settings->media audio behavior->bluetooth (dynamic) auto usage to checked. The A2DP box is also checked, the mono box is unchecked.
3) Notifications is set to Current Phone setting, same for Ringtones.

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Sun Aug 09, 2015 6:15 pm

More information from today.
This morning I opened SoundAbout and turned it on. Later on I turned it off. I then turned on my bluetooth headset. When a phone call came in I pressed my headset button to answer the call and it answered; however all of the audio when through my phone's speaker. I couldn't get the audio into my headset at all, even by changing the options in the phone app. So it appears that SoundAbout isn't resetting the audio when it turns off. I have SoundAbout set to let app decide for phone calls.

Later today I was listening to a podcast through my mono bluetooth headset with SoundAbout enabled. This worked well. When I was finished I turned off my headset. SoundAbout said phone speaker for media. I then set an alarm to test and only got the beep rather than the alarm tone. I then opened my podcast app and started it playing audio and reset the alarm to see if playing audio through the speaker would help. It didn't, I just got the single beep and no alarm tone. I then turned off SoundAbout and set my alarm again; again no alarm tone, just the beep. I went into settings and told SoundAbout and SoundAbout Pro Key to stop and reset the alarm; now I get the alarm tone.

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Mon Aug 10, 2015 1:10 am

Can you try the latest Beta version to see if it helps Alarms / Notifications after using Bluetooth mono for podcasts?

The Beta versions are here:
http://soundabout.userboard.net/f8-download-beta-versions


Last edited by SoundAbout on Mon Aug 10, 2015 1:21 pm; edited 1 time in total
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Mon Aug 10, 2015 8:35 am

Note that I'm not using a wired headset, only bluetooth. I'll download the beta and try it today.

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Mon Aug 10, 2015 1:21 pm

Whoops, I meant "Alarms / Notifications after using Bluetooth mono for podcasts". I copied and pasted from another thread by mistake.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Tue Aug 11, 2015 8:19 am

I tested it yesterday and so far it's working quite well. Calendar and alarm tones play as expected once I've turned off my headset. Podcasts play through the headset as they always have. I haven't needed to go into the app to change settings, which is good.

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Tue Aug 11, 2015 8:48 am

OK, good.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Thu Aug 13, 2015 8:17 am

I've been using the beta for the last 3 days without issue. How will I switch back to the stable releases once it's out?

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Thu Aug 13, 2015 8:35 am

You will get prompted to download it when I publish to Google Play store. I can leave the Beta releases posted on the message board, if you need to go backwards.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Wed Sep 02, 2015 1:12 pm

I updated to 2.6.5.5 yesterday and the problem is back. I started up SOundAbout this morning. Listened to a podcast with bluetooth mono dynamic. When I got to work I turned off my headset. A little bit later I received a calendar notification and I just got a beep, not the normal sound. I then turned off SoundAbout. A little later I received a text message and the text notification was just the beep, not the normal tone. I killed off SoundAbout using force stop in the system settings. After this alerts play the correct tones.

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Thu Sep 03, 2015 10:26 am

I'm working on a way to store, and put back, the interruption settings used in Android 5.0 and above.

In Android 5.0, the interruptions settings are available, but they didn't give a way for apps to put the settings back, if your app has changed them by messing with the audio settings.

In Android 5.1, there is a way to fix the settings. I am trying to see if I can find a way to fix the settings in 5.0 as well.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Thu Sep 03, 2015 10:43 am

And I'm running 4.4.2 which I'm sure further complicates things.

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Mon Sep 07, 2015 10:20 pm

I just uploaded a new Beta version.

Can you download it and try it out from here. Restart the phone after installing:
http://soundabout.userboard.net/f8-download-beta-versions
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by jpschewe on Wed Sep 09, 2015 9:54 pm

This is working with the beta version 2.6.5.6.

jpschewe

Posts : 27
Join date : 2015-07-31

View user profile

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by SoundAbout on Wed Sep 09, 2015 9:55 pm

Excellent, thank you.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Alarms don't play with SoundAbout running

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum