Sound device input lost on reboot

View previous topic View next topic Go down

Sound device input lost on reboot

Post by zuzu11 on Tue Jun 24, 2014 5:19 pm

Hello , I have one problem, maybe you can help. I have bought the Soundabout Pro app, and I am running in some trouble. I am using an mk808B android tv stick, with 4.2.2 firmware. I also have one Mele F10 Pro wireless -mouse - remote, wich has build in speaker, headphone jack and mic . The problem,and why I bought soundabout in the first place, is that everytime I restart my android stick. the default sound output is set to mediotek usb etc.. wich is the remote's soundcard. No matter how many times I change to hdmi, it goes back to remote's audio. So I got sound about and problem solved. However, one more problem. I also have a Microsoft live webcam, wich has integrated microphone, and I chose this by default, as sound input (for Skype), but after every reboot, sound input goes back to remote's built-in microphone. The question is, any chance you would release an update or something like that, to make sound about able to do the same for sound input, what it does for sound output ? wich is memorise this setting, so it does not go back to some other input device that the one that I choose by default ? thank you. If it is too much trouble, maybe you could make an in-app purchase, and I will definetly buy it, and I believe there are plenty more people in my situation wich need this, and are willing to buy the "solution".

zuzu11

Posts : 7
Join date : 2014-06-24

View user profile

Back to top Go down

Re: Sound device input lost on reboot

Post by SoundAbout on Fri Jun 27, 2014 10:57 pm

I don't have a MK808B android tv stick so I can't really test this setup.

You mentioned that the HDMI works. Do you set the "Media audio" setting to "Aux Digital (HDMI)" or is the "Media audio" setting on "Let app decide" and it detected when you plugged in the HDMI cable?

When the WebCam plugs into the MK808B via USB, then the MK808B would be plugged into the TV via HDMI and the WebCam via USB. The Android OS unfortualtly doesn't have an easy universal way to get this to work via SoundAbout. From what I read, various ROMS will enable certain web cams to work with the MK808B.

Here is what I found:
http://www.androydz.com/skype-on-android-mini-pc/#Skype_on_MK808MK808B

http://www.armtvtech.com/armtvtechforum/viewtopic.php?f=6&t=841
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Sound device input lost on reboot

Post by becks922 on Sat Jun 28, 2014 3:10 am

The Webcam is a Microsoft Lifecam VX-2000, and it is fully compatible with Skype. If i remove the mele f10 pro keyboard and use a mouse, than run skype with webcam it runs perfectly. But leaving the mele f10 pro remote connected, i have to manually go in settings and select manually VX-2000 at sound input (the microphone), because it always goes back to modiotek usb ... (wich is the name of the remote's sound card, probably).

I tryed media audio set to Aux Digital HDMI ,and it works, for sound output. I also tryed setting to SPEAKERS, that also works to. Don't get me wrong, sound output is fine, just the input method bothers me.

So, as i said the webcam gets along just fine with skype, i bought it after reading reviews.

So it's not possible to make a setting in soundabout to change 2 things ? Because in android settings, at the sound device manager there are 2 settings, output, and input, and as far as i see soundabout only alters the output.


becks922

Posts : 3
Join date : 2014-06-24

View user profile

Back to top Go down

Re: Sound device input lost on reboot

Post by becks922 on Sat Jun 28, 2014 3:10 am

BTW i already read those 2 topics you sent me few times, there's nothing new for me there.

becks922

Posts : 3
Join date : 2014-06-24

View user profile

Back to top Go down

Re: Sound device input lost on reboot

Post by SoundAbout on Sat Jun 28, 2014 11:45 pm

I found the thread that discusses using SoundAbout to solve the audio issue.
http://forum.mele.cn:81/viewtopic.php?f=19&t=39&start=20

Normally, the Audio output and input are linked. The only time I can split the audio output/input is when SoundAbout setting for Bluetooth (mono) microphone override is turned on. This allows using a Bluetooth microphone with other audio outputs.

The WebCam is plugged into the MK808 via USB. Android doesn't really have USB Audio API for me to use. I wonder if MK808 is using some proprietary USB driver like these guys do.
http://www.extreamsd.com/USBAudioRecorderPRO/

What happens if you set the SoundAbout "Media audio" setting to "USB Host"?

avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Sound device input lost on reboot

Post by zuzu11 on Sun Jun 29, 2014 6:27 am

Setting SoundAbout media audio to usb Host, i get the fallowing message: Please plug in USB client device for this setting, than after 1 minute or less message dissapears. I tryed restart after that, i am getting same warning (probably when soundabout gets loaded) , than message dissapears, and sound output still works, but it's same thing as before with the microphone (sound input).
Same thing happend after i tryed unplug/plug again the webcam. Still, same thing after restart.
And , in both cases, after restart, my USB Ethernet adapter(yes, i'm using one) gets disables, and there is no way turning it back on, everytime set it to ON from android settings, it switches back OFF.
So, i have put SoundAbout media audio back to hdmi.
So.. what next, do you have another ideea ?

zuzu11

Posts : 7
Join date : 2014-06-24

View user profile

Back to top Go down

Re: Sound device input lost on reboot

Post by SoundAbout on Mon Jun 30, 2014 3:05 pm

OK, so the WebCam is not using USB Host mode. I didn't think so.

Is your MK808 using a version of Android made for the MK808 or are you using a custom ROM?

I'm wondering if those settings that you are updating to get it to work are pointing to proprietary code for the MK808.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Sound device input lost on reboot

Post by zuzu11 on Mon Jun 30, 2014 3:12 pm

I am using a version of android, 4.2.2 that is specially made for mk808b (original) wich has been slightly modyfied, calles finless 2.1 rom. You can find that on freaktab forum, if that helps, and same for the info that says what has been modified on it.

zuzu11

Posts : 7
Join date : 2014-06-24

View user profile

Back to top Go down

Re: Sound device input lost on reboot

Post by zuzu11 on Sat Jul 05, 2014 8:45 am

So.. anything new ? My problem is still there

zuzu11

Posts : 7
Join date : 2014-06-24

View user profile

Back to top Go down

Re: Sound device input lost on reboot

Post by SoundAbout on Sun Jul 06, 2014 10:21 pm

From what I found, it doesn't look like something SoundAbout can do from an app. Since this is special driver for that device (with it's own settings), it looks like something would have to be done in the ROM or kernel.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Sound device input lost on reboot

Post by zuzu11 on Thu Jul 10, 2014 1:15 am

Problem fixed.
The solution - I changed the Mele f10 Pro keyboard for Mele F10 basic, wich doesn't have a sound card.

zuzu11

Posts : 7
Join date : 2014-06-24

View user profile

Back to top Go down

Re: Sound device input lost on reboot

Post by SoundAbout on Fri Jul 11, 2014 4:43 pm

Makes sense. Just get rid of the audio output and the audio goes elsewhere.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: Sound device input lost on reboot

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum