No sound at all

View previous topic View next topic Go down

No sound at all

Post by AngeloGomes on Fri Apr 11, 2014 8:51 am

First of all, congratulations for development of this app. Since the first time I run the "demo" version I realized that you did a great job and therefore I purchased the Pro key, even with app not working for me.

Well, let me try to explain what happen in my case.

I am trying to use the phone to send the navigation sound to my bluetooth car radio using waze. My phone is a S3 mini not rooted.

1) with the radio and phone paired, the radio reports it is connected through phone audio and multiamedia audio, which is correct as I bluetooth on settings on the phone are the same.

2)Without any special app installed on the phone, no sound from Waze is heard on phone or radio, however phone calls works.

3) installing AudioBT Plus app, I had the "partial success", i.e, I can hear waze navigation on the phone but with a too low volume. The radio is not interrupted anytime.

4) Then I tried SoundAbout. Following the instructions in your posts, simply I have the same behavior reported on item 1 , i.e., no sound at all, anywhere.

I was suspecting the SoundAbout was not running, as I did not see any icon on the status bar, but I've found the settings hidden Laughing inside some menu Razz . So now, I see the icon on the status bar and see the notifications too.


AngeloGomes

Posts : 10
Join date : 2014-04-10

View user profile

Back to top Go down

Re: No sound at all

Post by AngeloGomes on Sat Apr 12, 2014 4:18 pm

I have been trying several settings and now I figure out some other behavior

Now I can reproduce sometimes the behavior 3. This indicates, at least to me, that soundabout works differently as AudioBT. When I say sometimes, it is because it stops to work and I don´t know why.

Today, playing around with the TTS sample audio, sometimes I noticed the car radio showing "end of communication". Sometimes the radio sound is interrupted, but nothing is heard on it or on phone. The strange thing is that it is completely random this behavior. Sometimes it shows "end of communication", sometimes it does not.





AngeloGomes

Posts : 10
Join date : 2014-04-10

View user profile

Back to top Go down

Re: No sound at all

Post by SoundAbout on Sat May 03, 2014 2:01 pm

Sorry, just getting caught up on messages.

If you are using the Text To Speech to Bluetooth mono method, you will get better results if the navigation app uses more Text To Speech when sending directions. With Waze, the direction audio might be pre-recorded, so it won't require Text To Speech and thus won't allow SoundAbout to switch the audio.

Instead of using Text To Speech, both SoundAbout and AudioBT can try and detected the audio and then switch Bluetooth dynamically. In SoundAbout, this is called "Bluetooth (mono) (dynamic). To use this method, you would want to NOT use SoundAbout TTS at the same time. This method will work with pre-recorded audio or Text To Speech, but the issue with this method is that you will miss a second or two of audio due to the fact that Bluetooth mono takes a couple seconds to connect.

When using the SoundAbout Text To Speech method, SoundAbout will get the TTS request and put it in a queue. While queued, SoundAbout will switch the audio and wait for X number of seconds (delay setting). Then SoundAbout will allow the queued TTS text to be processed and the audio will come out of the desired output (Bluetooth in car). Like I said above, for this to work, the Navigation app MUST be using Text To Speech. If it uses Text To Speech for ONLY the street names then any directions that don't use TTS will most likely come out of the phone speaker instead of the Car speakers. SoundAbout can't really do much about this because it NEEDS to know when the audio is about to be broadcast.

In summary, when using Bluetooth (mono) (dynamic), this can be done, but the audio cannot be paused while switch audio to Bluetooth. While using Text To Speech, the audio can be paused while switching to Bluetooth, but the Navigation app needs to always use Text To Speech. I tend to have better results with Google Navigation. To get rid of the pre-recorded messages in Google Maps Navigation, I do the following:
http://soundabout.userboard.net/t201-get-rid-of-double-voice-when-using-google-navigation-and-soundabout-tts



avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: No sound at all

Post by AngeloGomes on Fri May 09, 2014 1:55 pm

Hi, let me ask you a question. I have downloaded a beta version 2.5.8.0.8 and now I had at least something usefull, although no sound is directed to bluetooth.

Let me explain:

I set:

Media audio: bt a2dp
Phone call audio: bt mono
TTS audio: bt mono (have to check this)

result: every bt combination gives no sound on Maps and Waze.

------------
Media audio: speaker
Phone call audio: bt mono
TTS audio: bt modo dynamic (have to check this)

result: every bt combination gives sound on phone speaker (Maps and Waze) but the volume start loud and then decreases 2 sec after to almost something that I can't hear.

----------------------------

Media audio: speaker
Phone call audio: bt mono
TTS audio: speaker (have to check this)

result: this fixed the previous issue. The volume is loud all the time on the speaker phone. I can hear the radio and receive phone call at the car radio. This is a great improvement.

As i can see in other forum, many people had that volume issue and SoundAbout fixed this although it was not its main purpose.

--------------------------------------------------------


Now I have to understand why the bt car radio is not interrupted by Soundabout redirection when I set it to do.


Well, at least, now I can hear the navigation info from the speaker at the smatphone.

Do you think it is worth to try older versions ?





AngeloGomes

Posts : 10
Join date : 2014-04-10

View user profile

Back to top Go down

Re: No sound at all

Post by SoundAbout on Fri May 09, 2014 3:17 pm

Media audio: This can be set to "Let app decide". Bluetooth A2DP will automatically be used if connected.

Phone call audio: This can be set to "Let app decide". Bluetooth mono will automatically be used if connected.

Waze may not work if it is not using Text To Speech. I know some voices use Text To Speech for street names and others do not. If waze plays any audio that does not use Text To Speech, then it will come out of the phone speaker.

Google Maps will use Text To Speech in most cases.

Android TTS Settings: The SoundAbout TTS Engine must be selected

TTS audio output: bt mono
TTS Max utterance: Two
TTS Delay utterance: 2.5 secs




avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: No sound at all

Post by AngeloGomes on Fri May 09, 2014 6:19 pm

Hi, thank you. I will use your settings when I get out with the car.

I´ve just arrived and some new insights and tests.

It seems that any other TTS engine different from Google TTS one will cause the problems.

I had success to hear the sample text using Google TTS engine and sending to bt A2DP (great !!!). As I said, if I use other TTS Engine it does not work.

I tested now using Google TTS engine and TTS audio output: bt mono dyn. Now, I noticed that sometimes the radio get silent but no sound  from TTS is heard. Sometime, the sound on the radio is not interrupted as before, but I noticed after 5-6 sec the message appears at the radio "end of communication". I concluded the soundabout is really trying to connect to the radio, but for some reason it does not start or it does not end the communication. It seems a timming issue or something is missing during the protocol initial communication .

Today I am 70% satisfied with results.

AngeloGomes

Posts : 10
Join date : 2014-04-10

View user profile

Back to top Go down

Re: No sound at all

Post by SoundAbout on Fri May 09, 2014 6:44 pm

So you changed the "real" TTS engine from withing the SoundAbout TTS settings and it didn't work?

What other TTS engines are on the phone? I've used the built-in Google and Pico Engines without an issue.

For the TTS media audio settings, don't use "Bluetooth (dynamic)". Use "Bluetooth (mono)". I will most likely be getting rid of "Bluetooth (dynamic)" for Text To Speech as it doesn't have value in that scenario.

From the main SoundAbout media audio setting, "Bluetooth (mono)(dynamic)" will detect audio and switch the audio output to Bluetooth mono. For notifications, this might not work or will have such a delay that you will miss the notification, but for things like pod casts were you want to play over the car speakers only when connected to Bluetooth in the car, it will work well.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: No sound at all

Post by AngeloGomes on Fri May 09, 2014 7:11 pm

Yes, changing the TTS inside the TTS SoundAbout.

Only Google TTS Engine Worked 100%. Samsung TTS the sound gets too low if used with SoundAbout. Loquendo TTS does not work, no matter the settings I use.

Tomorrow I will test using your settings..

AngeloGomes

Posts : 10
Join date : 2014-04-10

View user profile

Back to top Go down

Re: No sound at all

Post by SoundAbout on Sat May 10, 2014 12:06 am

Unfortunately, I don't have Samsung TTS and I don't see Loquendo TTS on Google Play anymore.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: No sound at all

Post by AngeloGomes on Sat May 10, 2014 8:22 am

No prpb. I will use Google tts from now.

AngeloGomes

Posts : 10
Join date : 2014-04-10

View user profile

Back to top Go down

Re: No sound at all

Post by SoundAbout on Sat May 10, 2014 11:05 am

Where did you get Loquendo TTS? I'm trying to find a download to test with.
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: No sound at all

Post by AngeloGomes on Sat May 10, 2014 4:20 pm

I have it for a long time, really I dont remember exactly, I can suppose it was in Google Play. Googling for it I saw people reporting that it was purchased from Nuance and since them removed  from Google Play.

but anyway, I am using Google Engine now.

Well, I did set as you said, but no way. The radio is never interrupted by SoundAbout, only if I set the source as media bluetooth , which of course, does not allow me to listen to the  radio stations.

I have also tested with a LG smartphone and the results were the same.

AngeloGomes

Posts : 10
Join date : 2014-04-10

View user profile

Back to top Go down

Re: No sound at all

Post by SoundAbout on Sun May 11, 2014 9:59 am

Do you have the version of SoundAbout in Google Play or the latest Beta version?

The latest Beta version can be downloaded here:
http://soundabout.userboard.net/f8-download-beta-versions
avatar
SoundAbout
Admin

Posts : 1492
Join date : 2013-04-26
Location : Boston, MA

View user profile http://soundabout.userboard.net/

Back to top Go down

Re: No sound at all

Post by AngeloGomes on Sun May 11, 2014 2:32 pm

the latest Beta 2.5.8.0.8

AngeloGomes

Posts : 10
Join date : 2014-04-10

View user profile

Back to top Go down

Re: No sound at all

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum